Gamers' Lounge :  Conqueror! Forum
Arrange meeting times for new games, discuss past games and strategies, socialize with other players. 
Playing is pointless
Posted by: Baldrik ()
Date: October 14, 2012 05:03PM

This looks like the kind of game I'd love, so I tried to play it. I've tried 6 solo games so far and every single one of them has either frozen, crashed, or just stopped mid-turn. There's no way to resume because there is no save function (seriously?). I waste an hour of my life per game just to get so frustrated when it breaks that I want to throw something. Is the solo feature busted? Am I just not seeing a "Save Game" button? Am I the only one having these problems?

Edited 1 time(s). Last edit at 10/14/2012 05:37PM by Baldrik.

Options: ReplyQuote
Re: Playing is pointless
Posted by: Insurrection ()
Date: October 16, 2012 11:48PM

yo bro its probaly cuz ur internet connection tryy online game when some1 else is host

Insurrection is infection

Options: ReplyQuote

Sorry, only registered users may post in this forum.